version=pmwiki-2.2.130 ordered=1 urlencoded=1 agent=Mozilla/5.0 (X11; OpenBSD amd64; rv:76.0) Gecko/20100101 Firefox/76.0 author=jrmu charset=UTF-8 csum= ctime=1597239732 host=38.81.163.143 name=Vps.Intro rev=3 targets= text=You can run any Linux or BSD-based operating system on your VPS as a guest inside OpenBSD.%0a%0aYou will be given a username and password for your account. This will create a username on our host system:%0a%0a[@%0a$ ssh username@coconut.ircnow.org%0a@]%0a%0aECDSA key fingerprint is SHA256:a0LIR/BRZkpYqMho/YvkISPEm7vkus5QfOSqAeu+tYc.%0a%0a**Please note**: This is the host machine, not your VM. The host machine is running OpenBSD but your guest VPS can run any OS.%0a%0aOnce you log in, you can access the serial console:%0a%0a[@%0a$ vmctl console %3cvm-name>%0a@]%0a%0aTo shutdown the VM:%0a%0a[@%0a$ vmctl stop %3cvm-name>%0a@]%0a%0aTo boot the VM:%0a%0a[@%0a$ vmctl start %3cvm-name>%0a@]%0a%0aTo pause the VM:%0a%0a[@%0a$ vmctl pause %3cvm-name>%0a@]%0a%0aTo unpause the VM:%0a%0a[@%0a$ vmctl unpause %3cvm-name>%0a@]%0a%0aTo escape serial console, type ~~. %0a%0a----%0a%0aTo connect to your VM, you will be given an IP address. In case you forget, your IP address can be found by running $ dig username.coconut.ircnow.org. Our default gateway is 38.81.163.129.%0a%0aFor convenience, you can log in to your VPS as follows:%0a%0a[@%0a$ ssh username@username.coconut.ircnow.org%0a@]%0a%0aPlease note that this hostname is different from the host; there is an extra username in username.coconut.ircnow.org.%0a%0a----%0a%0aTo reinstall OpenBSD 6.6:%0a%0a[@%0a$ ssh username@coconut.ircnow.org%0a$ cd ~%0a$ rm username.qcow2%0a$ vmctl create -s 20G username.qcow2%0a$ vmctl start username%0a$ vmctl start username%0a$ vmctl console username%0a@]%0a%0aMake sure to configure static networking as well as to set up ping in the background as outlined below.%0a%0a----%0a%0aFor OpenBSD, here is how you statically assign your IP address:%0a%0aInside /etc/hostname.vio0:%0a%0a[@%0ainet 38.81.163.xxx 255.255.255.0%0a@]%0a%0aReplace 38.81.163.xxx with your assigned IP address.%0a%0aInside /etc/mygate:%0a%0a[@%0a38.81.163.129%0a@]%0a%0aFor Alpine:%0a%0aTo restart networking:%0a%0a[@%0a# service networking restart%0a@]%0a%0aFor Debian:%0a%0a[@%0asystemctl restart networking%0a@]%0a%0aInside /etc/network/interfaces:%0a%0a[@%0asource /etc/network/interfaces.d/*%0a%0a# The loopback network interface%0aauto lo%0aiface lo inet loopback%0a%0a# The primary network interface%0aauto enp0s2%0aiface enp0s2 inet static%0a address 38.81.163.x%0a netmask 255.255.255.0%0a gateway 38.81.163.129%0a@]%0a%0a----%0a%0aLosing network connectivity:%0a%0aFor OpenBSD, put this in your crontab:%0a%0a[@%0a@reboot /usr/bin/tmux new -d 'while true; do /sbin/ping -i5 38.81.163.129; done' \;%0a@]%0a%0aAfterwards, to ensure it runs right away, execute this once:%0a%0a[@%0a/usr/bin/tmux new -d 'while true; do /sbin/ping -i5 38.81.163.129; done' \;%0a@]%0a%0aFor Debian:%0a%0a[@%0a@reboot /usr/bin/tmux new -d 'while true; do /usr/bin/ping -i5 38.81.163.129; done' \;%0a@]%0a%0aAfterwards, to ensure it runs right away, execute this once:%0a%0a[@%0a/usr/bin/tmux new -d 'while true; do /usr/bin/ping -i5 38.81.163.129; %0a@]%0a%0aFor Alpine:%0a%0a[@%0a@reboot /usr/bin/tmux new -d 'while true; do /bin/ping -i5 38.81.163.129; done' \;%0a@]%0a%0aAfterwards, to ensure it runs right away, execute this once:%0a%0a[@%0a/usr/bin/tmux new -d 'while true; do /bin/ping -i5 38.81.163.129; done' \;%0a@]%0a%0a----%0a%0aTo reinstall OpenBSD:%0a%0aFirst, log in to the host:%0a%0a[@%0a$ ssh username@coconut.ircnow.org%0a$ vmctl stop username%0a$ rm username.qcow2%0a$ vmctl create -s 20G username.qcow2%0a$ vmctl start username%0a$ vmctl console username%0a@]%0a%0aThen, do the installation as usual. time=1602318157 author:1602318157=jrmu diff:1602318157:1602318037:= host:1602318157=38.81.163.143 author:1602318037=jrmu diff:1602318037:1597239732:=5,8c5,8%0a%3c [@%0a%3c $ ssh username@coconut.ircnow.org%0a%3c @]%0a%3c %0a---%0a> %3ccode>%0a> $ ssh username@us5.ircnow.org%0a> %3c/code>%0a> %0a15c15%0a%3c [@%0a---%0a> %3ccode>%0a17,18c17,18%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a21c21%0a%3c [@%0a---%0a> %3ccode>%0a23,24c23,24%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a27c27%0a%3c [@%0a---%0a> %3ccode>%0a29,30c29,30%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a33c33%0a%3c [@%0a---%0a> %3ccode>%0a35,36c35,36%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a39c39%0a%3c [@%0a---%0a> %3ccode>%0a41,42c41,42%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a47,48c47,48%0a%3c To connect to your VM, you will be given an IP address. In case you forget, your IP address can be found by running $ dig username.coconut.ircnow.org. Our default gateway is 38.81.163.129.%0a%3c %0a---%0a> To connect to your VM, you will be given an IP address. In case you forget, your IP address can be found by running $ dig username.us5.ircnow.org. Our default gateway is 38.81.163.129.%0a> %0a51,56c51,56%0a%3c [@%0a%3c $ ssh username@username.coconut.ircnow.org%0a%3c @]%0a%3c %0a%3c Please note that this hostname is different from the host; there is an extra username in username.coconut.ircnow.org.%0a%3c %0a---%0a> %3ccode>%0a> $ ssh username@username.us5.ircnow.org%0a> %3c/code>%0a> %0a> Please note that this hostname is different from the host; there is an extra username in username.us5.ircnow.org.%0a> %0a61,62c61,62%0a%3c [@%0a%3c $ ssh username@coconut.ircnow.org%0a---%0a> %3ccode>%0a> $ ssh username@us5.ircnow.org%0a69,70c69,70%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a79c79%0a%3c [@%0a---%0a> %3ccode>%0a81,82c81,82%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a87c87%0a%3c [@%0a---%0a> %3ccode>%0a89,90c89,90%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a95c95%0a%3c [@%0a---%0a> %3ccode>%0a97,98c97,98%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a101c101%0a%3c [@%0a---%0a> %3ccode>%0a103,104c103,104%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a107c107%0a%3c [@%0a---%0a> %3ccode>%0a120,121c120,121%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a128c128%0a%3c [@%0a---%0a> %3ccode>%0a130,131c130,131%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a134c134%0a%3c [@%0a---%0a> %3ccode>%0a136,137c136,137%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a140c140%0a%3c [@%0a---%0a> %3ccode>%0a142,143c142,143%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a146c146%0a%3c [@%0a---%0a> %3ccode>%0a148,149c148,149%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a152c152%0a%3c [@%0a---%0a> %3ccode>%0a154,155c154,155%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a158c158%0a%3c [@%0a---%0a> %3ccode>%0a160,161c160,161%0a%3c @]%0a%3c %0a---%0a> %3c/code>%0a> %0a168,169c168,169%0a%3c [@%0a%3c $ ssh username@coconut.ircnow.org%0a---%0a> %3ccode>%0a> $ ssh username@us5.ircnow.org%0a175c175%0a%3c @]%0a---%0a> %3c/code>%0a host:1602318037=38.81.163.143 author:1597239732=jrmu diff:1597239732:1597239732:=1,177d0%0a%3c You can run any Linux or BSD-based operating system on your VPS as a guest inside OpenBSD.%0a%3c %0a%3c You will be given a username and password for your account. This will create a username on our host system:%0a%3c %0a%3c %3ccode>%0a%3c $ ssh username@us5.ircnow.org%0a%3c %3c/code>%0a%3c %0a%3c ECDSA key fingerprint is SHA256:a0LIR/BRZkpYqMho/YvkISPEm7vkus5QfOSqAeu+tYc.%0a%3c %0a%3c **Please note**: This is the host machine, not your VM. The host machine is running OpenBSD but your guest VPS can run any OS.%0a%3c %0a%3c Once you log in, you can access the serial console:%0a%3c %0a%3c %3ccode>%0a%3c $ vmctl console %3cvm-name>%0a%3c %3c/code>%0a%3c %0a%3c To shutdown the VM:%0a%3c %0a%3c %3ccode>%0a%3c $ vmctl stop %3cvm-name>%0a%3c %3c/code>%0a%3c %0a%3c To boot the VM:%0a%3c %0a%3c %3ccode>%0a%3c $ vmctl start %3cvm-name>%0a%3c %3c/code>%0a%3c %0a%3c To pause the VM:%0a%3c %0a%3c %3ccode>%0a%3c $ vmctl pause %3cvm-name>%0a%3c %3c/code>%0a%3c %0a%3c To unpause the VM:%0a%3c %0a%3c %3ccode>%0a%3c $ vmctl unpause %3cvm-name>%0a%3c %3c/code>%0a%3c %0a%3c To escape serial console, type ~~. %0a%3c %0a%3c ----%0a%3c %0a%3c To connect to your VM, you will be given an IP address. In case you forget, your IP address can be found by running $ dig username.us5.ircnow.org. Our default gateway is 38.81.163.129.%0a%3c %0a%3c For convenience, you can log in to your VPS as follows:%0a%3c %0a%3c %3ccode>%0a%3c $ ssh username@username.us5.ircnow.org%0a%3c %3c/code>%0a%3c %0a%3c Please note that this hostname is different from the host; there is an extra username in username.us5.ircnow.org.%0a%3c %0a%3c ----%0a%3c %0a%3c To reinstall OpenBSD 6.6:%0a%3c %0a%3c %3ccode>%0a%3c $ ssh username@us5.ircnow.org%0a%3c $ cd ~%0a%3c $ rm username.qcow2%0a%3c $ vmctl create -s 20G username.qcow2%0a%3c $ vmctl start username%0a%3c $ vmctl start username%0a%3c $ vmctl console username%0a%3c %3c/code>%0a%3c %0a%3c Make sure to configure static networking as well as to set up ping in the background as outlined below.%0a%3c %0a%3c ----%0a%3c %0a%3c For OpenBSD, here is how you statically assign your IP address:%0a%3c %0a%3c Inside /etc/hostname.vio0:%0a%3c %0a%3c %3ccode>%0a%3c inet 38.81.163.xxx 255.255.255.0%0a%3c %3c/code>%0a%3c %0a%3c Replace 38.81.163.xxx with your assigned IP address.%0a%3c %0a%3c Inside /etc/mygate:%0a%3c %0a%3c %3ccode>%0a%3c 38.81.163.129%0a%3c %3c/code>%0a%3c %0a%3c For Alpine:%0a%3c %0a%3c To restart networking:%0a%3c %0a%3c %3ccode>%0a%3c # service networking restart%0a%3c %3c/code>%0a%3c %0a%3c For Debian:%0a%3c %0a%3c %3ccode>%0a%3c systemctl restart networking%0a%3c %3c/code>%0a%3c %0a%3c Inside /etc/network/interfaces:%0a%3c %0a%3c %3ccode>%0a%3c source /etc/network/interfaces.d/*%0a%3c %0a%3c # The loopback network interface%0a%3c auto lo%0a%3c iface lo inet loopback%0a%3c %0a%3c # The primary network interface%0a%3c auto enp0s2%0a%3c iface enp0s2 inet static%0a%3c address 38.81.163.x%0a%3c netmask 255.255.255.0%0a%3c gateway 38.81.163.129%0a%3c %3c/code>%0a%3c %0a%3c ----%0a%3c %0a%3c Losing network connectivity:%0a%3c %0a%3c For OpenBSD, put this in your crontab:%0a%3c %0a%3c %3ccode>%0a%3c @reboot /usr/bin/tmux new -d 'while true; do /sbin/ping -i5 38.81.163.129; done' \;%0a%3c %3c/code>%0a%3c %0a%3c Afterwards, to ensure it runs right away, execute this once:%0a%3c %0a%3c %3ccode>%0a%3c /usr/bin/tmux new -d 'while true; do /sbin/ping -i5 38.81.163.129; done' \;%0a%3c %3c/code>%0a%3c %0a%3c For Debian:%0a%3c %0a%3c %3ccode>%0a%3c @reboot /usr/bin/tmux new -d 'while true; do /usr/bin/ping -i5 38.81.163.129; done' \;%0a%3c %3c/code>%0a%3c %0a%3c Afterwards, to ensure it runs right away, execute this once:%0a%3c %0a%3c %3ccode>%0a%3c /usr/bin/tmux new -d 'while true; do /usr/bin/ping -i5 38.81.163.129; %0a%3c %3c/code>%0a%3c %0a%3c For Alpine:%0a%3c %0a%3c %3ccode>%0a%3c @reboot /usr/bin/tmux new -d 'while true; do /bin/ping -i5 38.81.163.129; done' \;%0a%3c %3c/code>%0a%3c %0a%3c Afterwards, to ensure it runs right away, execute this once:%0a%3c %0a%3c %3ccode>%0a%3c /usr/bin/tmux new -d 'while true; do /bin/ping -i5 38.81.163.129; done' \;%0a%3c %3c/code>%0a%3c %0a%3c ----%0a%3c %0a%3c To reinstall OpenBSD:%0a%3c %0a%3c First, log in to the host:%0a%3c %0a%3c %3ccode>%0a%3c $ ssh username@us5.ircnow.org%0a%3c $ vmctl stop username%0a%3c $ rm username.qcow2%0a%3c $ vmctl create -s 20G username.qcow2%0a%3c $ vmctl start username%0a%3c $ vmctl console username%0a%3c %3c/code>%0a%3c %0a%3c Then, do the installation as usual.%0a\ No newline at end of file%0a host:1597239732=38.81.163.143