version=pmwiki-2.2.130 ordered=1 urlencoded=1 agent=Mozilla/5.0 (Linux; Android 8.1.0; vivo 1820 Build/O11019) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/107.0.5304.141 Mobile Safari/537.36 author=Yonle charset=UTF-8 csum= ctime=1671063012 host=62.210.245.177 name=Openbsd.Honk rev=18 targets=Acme-client.Configure text=(:title honk:)%0a[[https://humungus.tedunangst.com/r/honk|honk]] is an Activitypub software that focused on Single-user instance. \\%0a%0a!! Install%0a[[https://humungus.tedunangst.com/r/honk|honk]] is available at OpenBSD ports.%0a[@%0a# pkg_add honk%0a@]%0a%0a!! Configuring httpd.conf%0ahttpd will used for [[Acme-client.Configure|acme-client]]. Edit @@/etc/httpd.conf@@:%0a%0a[@%0a# $OpenBSD: httpd.conf,v 1.22 2020/11/04 10:34:18 denis Exp $%0a%0aserver "example.com" {%0a listen on * port 80%0a location "/.well-known/acme-challenge/*" {%0a root "/acme"%0a request strip 2%0a }%0a%0a location * {%0a block return 302 "https://$HTTP_HOST$REQUEST_URI"%0a }%0a}%0a@]%0a%0aReplace @@example.com@@ with your hostname.%0a%0aCheck the configuration with @@httpd -n@@, if it is OK enable and start relayd (as root):%0a[@%0a# rcctl enable httpd%0a# rcctl start httpd%0a@]%0a%0a!! Configuring relayd.conf%0arelayd will be used as the reverse proxy sitting in front of honk. Insert the following configuration in @@/etc/relayd.conf@@:%0a%0a[@%0a# $OpenBSD: relayd.conf,v 1.4 2018/03/23 09:55:06 claudio Exp $%0a%0aext_inet="%3cIPv4 address>"%0aext_inet6="%3cIPv6 address>"%0a%0atable %3chonk_server> { 127.0.0.1 }%0atable %3chttpd_server> { 127.0.0.1 }%0a%0ahttp protocol honk { # Protocol for upstream honk server%0a #tcp { nodelay, sack, socket buffer 65536, backlog 128 } # Uncomment and adjust as you see fit%0a tls { keypair example.com }%0a%0a # Append a bunch of headers%0a match request header append "X-Forwarded-For" value "$REMOTE_ADDR" # This two header and the next one are not strictly required by honk but adding them won't hurt%0a match request header append "X-Forwarded-By" value "$SERVER_ADDR:$SERVER_PORT"%0a%0a match request header append "Connection" value "upgrade"%0a}%0a%0arelay www {%0a listen on $ext_inet port https tls # Comment to disable listening on IPv4%0a%0a protocol honk%0a%0a forward to %3chonk_server> port 4000%0a}%0a%0arelay www6 {%0a listen on $ext_inet6 port https tls # Comment to disable listening on IPv6%0a%0a protocol honk%0a%0a forward to %3chonk_server> port 4000%0a}%0a@]%0a%0aChange @@example.com@@ with your instance domain.%0a%0aAgain, change @@%3cIPv4 address>@@ and @@%3cIPv6 address>@@ to your server's address(es) and comment one of the two listen options if needed.%0a%0aCheck the configuration with @@relayd -n@@, if it is OK enable and start relayd (as root):%0a[@%0a# rcctl enable relayd%0a# rcctl start relayd%0a@]%0a%0a!! Setting the honk up%0aWe need to access @@/var/honk@@ to setup database. So login as root%0a[@%0a$ doas su%0a@]%0a%0aGo to @@/var/honk@@, Then set up database.%0a[@%0a# cd /var/honk%0a# doas -u _honk honk init%0ausername: yourusername%0apassword:%0alistenaddr: 127.0.0.1:4000%0aservername: example.com%0a@]%0a%0aReplace @@yourusername@@ with your username, @@example.com@@ to your hostname.%0a%0aThen start the server.%0a[@%0a# rcctl start honk%0a@]%0a%0aIf server succesfully started, You may start it during boot.%0a[@%0a# rcctl enable honk%0a@]%0a%0aFinally, You can visit https://example.com to see your instance.%0a%0aYou may also adjust your instance settings by doing @@doas -u _honk honk admin@@ (Every @@honk@@ command must be run under @@_honk@@ user). Also read @@honk(1)@@%0a%0a!! Managing users%0a[[https://humungus.tedunangst.com/r/honk|honk]] is actually focused for single user instance, But it can also used for multiple users.%0a%0a* Adding user can done by executing @@doas -u _honk honk adduser@@ %0a* Changing user password can done by executing @@doas -u _honk honk chpass@@ %0a* Deleting user can done by executing @@doas -u _honk honk deluser@@ %0a%0a!! User interface basic%0ahonk is also known for it's humorous UI. An post is a "honk". Here's some info to get you started:%0a%0aIn [[https://humungus.tedunangst.com/r/honk|honk]], The users that you follow is called as "honkers" which you can manage at @@menu -> honkers@@%0a%0a* @@it's honking time@@ will create a post%0a%0aPost Actions:%0a* @@bonk@@ repost, rehonk, or reblog.%0a* @@honk back@@ reply to a post%0a* @@zonk@@ Delete a post%0a* @@ack@@ like a post.%0a* @@badonk@@ react to a post.%0a%0aYou can modify the text by editing @@header.html@@ under @@views@@ directory. \\%0a \\%0aAnd you may also like customizing your instance by copying @@style.css@@ to @@local.css@@ and edit @@local.css@@ under @@views@@ directory.%0a%0a!! Also read%0a* [[https://humungus.tedunangst.com/r/honk/m|intro(1)]] - Introduction to Honk documentation%0a* [[https://humungus.tedunangst.com/r/honk/m/honk.1|honk(1)]] - User manual%0a* [[https://humungus.tedunangst.com/r/honk/m/honk.3|honk(3)]] - Honk API documentation%0a* [[https://humungus.tedunangst.com/r/honk/m/honk.5|honk(5)]] - Honk composition%0a* [[https://humungus.tedunangst.com/r/honk/m/honk.8|honk(8)]] - Administration manual%0a* [[https://humungus.tedunangst.com/r/honk/m/hfcs.1|hfcs(1)]] - Honk Filtering and Censorship System. time=1671266716 title=honk author:1671266716=Yonle diff:1671266716:1671266663:=145c145%0a%3c * [[https://humungus.tedunangst.com/r/honk/m|intro(1)]] - Introduction to Honk documentation%0a---%0a> * [[https://humungus.tedunangst.com/r/honk/m|intro(1)]] - Introduction to @@honk@@ documentation%0a147c147%0a%3c * [[https://humungus.tedunangst.com/r/honk/m/honk.3|honk(3)]] - Honk API documentation%0a---%0a> * [[https://humungus.tedunangst.com/r/honk/m/honk.3|honk(3)]] - @@honk@@ API documentation%0a host:1671266716=62.210.245.177 author:1671266663=Yonle diff:1671266663:1671266637:=144c144%0a%3c !! Also read%0a---%0a> !! See also%0a host:1671266663=62.210.245.177 author:1671266637=Yonle csum:1671266637=Also read -> See also diff:1671266637:1671266613:=144c144%0a%3c !! See also%0a---%0a> !! Also read%0a host:1671266637=62.210.245.177 author:1671266613=Yonle csum:1671266613=Link to manpage diff:1671266613:1671259692:=141,150c141,142%0a%3c \\%0a%3c And you may also like customizing your instance by copying @@style.css@@ to @@local.css@@ and edit @@local.css@@ under @@views@@ directory.%0a%3c %0a%3c !! Also read%0a%3c * [[https://humungus.tedunangst.com/r/honk/m|intro(1)]] - Introduction to @@honk@@ documentation%0a%3c * [[https://humungus.tedunangst.com/r/honk/m/honk.1|honk(1)]] - User manual%0a%3c * [[https://humungus.tedunangst.com/r/honk/m/honk.3|honk(3)]] - @@honk@@ API documentation%0a%3c * [[https://humungus.tedunangst.com/r/honk/m/honk.5|honk(5)]] - Honk composition%0a%3c * [[https://humungus.tedunangst.com/r/honk/m/honk.8|honk(8)]] - Administration manual%0a%3c * [[https://humungus.tedunangst.com/r/honk/m/hfcs.1|hfcs(1)]] - Honk Filtering and Censorship System.%0a\ No newline at end of file%0a---%0a> %0a> And you may also like customizing your instance by copying @@style.css@@ to @@local.css@@ and edit @@local.css@@ under @@views@@ directory.%0a\ No newline at end of file%0a host:1671266613=62.210.245.177 author:1671259692=Yonle diff:1671259692:1671196895:=142c142%0a%3c And you may also like customizing your instance by copying @@style.css@@ to @@local.css@@ and edit @@local.css@@ under @@views@@ directory.%0a\ No newline at end of file%0a---%0a> And you may also like customizing your instance by copying @@style.css@@ to @@local.css@@ and edit @@local.css@@ under @@views directory.%0a\ No newline at end of file%0a host:1671259692=62.210.245.177 author:1671196895=Yonle csum:1671196895=Honk already has it's own robots.txt rule. diff:1671196895:1671182085:=11,12c11,12%0a%3c httpd will used for [[Acme-client.Configure|acme-client]]. Edit @@/etc/httpd.conf@@:%0a%3c %0a---%0a> httpd will used to serve @@robots.txt@@. Edit @@/etc/httpd.conf@@:%0a> %0a22a23,24%0a> location "robots.txt" { root "/htdocs" }%0a> %0a51a54,56%0a> %0a> # Forward some paths to the local server (as honk won't respond to them as you might want)%0a> pass request quick path "/robots.txt" forward to %3chttpd_server>%0a host:1671196895=62.210.245.177 author:1671182085=Yonle diff:1671182085:1671146492:=144,147d143%0a%3c %0a%3c You can modify the text by editing @@header.html@@ under @@views@@ directory. \\%0a%3c %0a%3c And you may also like customizing your instance by copying @@style.css@@ to @@local.css@@ and edit @@local.css@@ under @@views directory.%0a\ No newline at end of file%0a host:1671182085=62.210.245.177 author:1671146492=Yonle diff:1671146492:1671121302:=125,130c125,130%0a%3c [[https://humungus.tedunangst.com/r/honk|honk]] is actually focused for single user instance, But it can also used for multiple users.%0a%3c %0a%3c * Adding user can done by executing @@doas -u _honk honk adduser@@ %0a%3c * Changing user password can done by executing @@doas -u _honk honk chpass@@ %0a%3c * Deleting user can done by executing @@doas -u _honk honk deluser@@ %0a%3c %0a---%0a> [[https://humungus.tedunangst.com/r/honk|honk]] is actually focused for single user instance, But it can also used for multiple users. \\%0a> %0a> - Adding user can done by executing @@doas -u _honk honk adduser@@ \\%0a> - Changing user password can done by executing @@doas -u _honk honk chpass@@ \\%0a> - Deleting user can done by executing @@doas -u _honk honk deluser@@ \\%0a> %0a132,143c132,141%0a%3c honk is also known for it's humorous UI. An post is a "honk". Here's some info to get you started:%0a%3c %0a%3c In [[https://humungus.tedunangst.com/r/honk|honk]], The users that you follow is called as "honkers" which you can manage at @@menu -> honkers@@%0a%3c %0a%3c * @@it's honking time@@ will create a post%0a%3c %0a%3c Post Actions:%0a%3c * @@bonk@@ repost, rehonk, or reblog.%0a%3c * @@honk back@@ reply to a post%0a%3c * @@zonk@@ Delete a post%0a%3c * @@ack@@ like a post.%0a%3c * @@badonk@@ react to a post.%0a---%0a> honk is also known for it's humorous UI. An post is a "honk". Here's some info to get you started: \\%0a> %0a> - @@it's honking time@@ will create a post \\%0a> %0a> Post Actions: \\%0a> - @@bonk@@ repost, rehonk, or reblog. \\%0a> - @@honk back@@ reply to a post \\%0a> - @@zonk@@ Delete a post \\%0a> - @@ack@@ like a post \\%0a> - @@badonk@@ react to a post.%0a\ No newline at end of file%0a host:1671146492=62.210.245.177 author:1671121302=Yonle diff:1671121302:1671121284:=129c129%0a%3c - Deleting user can done by executing @@doas -u _honk honk deluser@@ \\%0a---%0a> - Deleting user can dine by executing @@doas -u _honk honk deluser@@ \\%0a host:1671121302=45.35.105.170 author:1671121284=Yonle csum:1671121284=user management diff:1671121284:1671120837:=123,129d122%0a%3c %0a%3c !! Managing users%0a%3c [[https://humungus.tedunangst.com/r/honk|honk]] is actually focused for single user instance, But it can also used for multiple users. \\%0a%3c %0a%3c - Adding user can done by executing @@doas -u _honk honk adduser@@ \\%0a%3c - Changing user password can done by executing @@doas -u _honk honk chpass@@ \\%0a%3c - Deleting user can dine by executing @@doas -u _honk honk deluser@@ \\%0a host:1671121284=45.35.105.170 author:1671120837=Yonle diff:1671120837:1671085239:=121,122d120%0a%3c %0a%3c You may also adjust your instance settings by doing @@doas -u _honk honk admin@@ (Every @@honk@@ command must be run under @@_honk@@ user). Also read @@honk(1)@@%0a host:1671120837=45.35.105.170 author:1671085239=Yonle diff:1671085239:1671084823:=10,12c10,11%0a%3c !! Configuring httpd.conf%0a%3c httpd will used to serve @@robots.txt@@. Edit @@/etc/httpd.conf@@:%0a%3c %0a---%0a> !! Setting up%0a> We need to access @@/var/honk@@ to setup database. So login as root%0a14,28c13%0a%3c # $OpenBSD: httpd.conf,v 1.22 2020/11/04 10:34:18 denis Exp $%0a%3c %0a%3c server "example.com" {%0a%3c listen on * port 80%0a%3c location "/.well-known/acme-challenge/*" {%0a%3c root "/acme"%0a%3c request strip 2%0a%3c }%0a%3c %0a%3c location "robots.txt" { root "/htdocs" }%0a%3c %0a%3c location * {%0a%3c block return 302 "https://$HTTP_HOST$REQUEST_URI"%0a%3c }%0a%3c }%0a---%0a> $ doas su%0a31,33c16%0a%3c Replace @@example.com@@ with your hostname.%0a%3c %0a%3c Check the configuration with @@httpd -n@@, if it is OK enable and start relayd (as root):%0a---%0a> Go to @@/var/honk@@, Then set up database.%0a35,36c18,23%0a%3c # rcctl enable httpd%0a%3c # rcctl start httpd%0a---%0a> # cd /var/honk%0a> # doas -u _honk honk init%0a> username: yourusername%0a> password:%0a> listenaddr: 127.0.0.1:4000%0a> servername: example.com%0a39,41c26,28%0a%3c !! Configuring relayd.conf%0a%3c relayd will be used as the reverse proxy sitting in front of honk. Insert the following configuration in @@/etc/relayd.conf@@:%0a%3c %0a---%0a> Replace @@yourusername@@ with your username, @@example.com@@ to your hostname.%0a> %0a> Then start the server.%0a42a30,41%0a> # rcctl start honk%0a> @]%0a> %0a> If server succesfully started, You may start it during boot.%0a> [@%0a> # rcctl enable honk%0a> @]%0a> %0a> !! Configuring relayd.conf%0a> relayd will be used as the reverse proxy sitting in front of honk. Insert the following configuration in @@/etc/relayd.conf@@:%0a> %0a> [@%0a92,120c91%0a%3c !! Setting the honk up%0a%3c We need to access @@/var/honk@@ to setup database. So login as root%0a%3c [@%0a%3c $ doas su%0a%3c @]%0a%3c %0a%3c Go to @@/var/honk@@, Then set up database.%0a%3c [@%0a%3c # cd /var/honk%0a%3c # doas -u _honk honk init%0a%3c username: yourusername%0a%3c password:%0a%3c listenaddr: 127.0.0.1:4000%0a%3c servername: example.com%0a%3c @]%0a%3c %0a%3c Replace @@yourusername@@ with your username, @@example.com@@ to your hostname.%0a%3c %0a%3c Then start the server.%0a%3c [@%0a%3c # rcctl start honk%0a%3c @]%0a%3c %0a%3c If server succesfully started, You may start it during boot.%0a%3c [@%0a%3c # rcctl enable honk%0a%3c @]%0a%3c %0a%3c Finally, You can visit https://example.com to see your instance.%0a---%0a> And finally, You can visit https://example.com to see your instance.%0a host:1671085239=62.210.245.199 author:1671084823=Yonle csum:1671084823=Honk, not pleroma diff:1671084823:1671084796:=39c39%0a%3c relayd will be used as the reverse proxy sitting in front of honk. Insert the following configuration in @@/etc/relayd.conf@@:%0a---%0a> relayd will be used as the reverse proxy sitting in front of pleroma. Insert the following configuration in @@/etc/relayd.conf@@:%0a host:1671084823=62.210.245.199 author:1671084796=Yonle csum:1671084796=Badonk diff:1671084796:1671084780:=96c96%0a%3c - @@it's honking time@@ will create a post \\%0a---%0a> - @@it's honking time@@ will create a post \\ \\%0a host:1671084796=62.210.245.199 author:1671084780=Yonle csum:1671084780=Honk diff:1671084780:1671084763:=96c96%0a%3c - @@it's honking time@@ will create a post \\ \\%0a---%0a> - @@it's honking time@@ will create a post \\%0a host:1671084780=62.210.245.199 author:1671084763=Yonle csum:1671084763=Honk diff:1671084763:1671063096:=94,95c94,95%0a%3c honk is also known for it's humorous UI. An post is a "honk". Here's some info to get you started: \\%0a%3c %0a---%0a> honk is also known for it's humorous UI. Here's some UI info to get you started: \\%0a> %0a97,99c97%0a%3c %0a%3c Post Actions: \\%0a%3c - @@bonk@@ repost, rehonk, or reblog. \\%0a---%0a> - @@bonk@@ repost, or reblog. \\%0a103c101%0a%3c - @@badonk@@ react to a post.%0a\ No newline at end of file%0a---%0a> - @@badonk@@ react to a post \\%0a\ No newline at end of file%0a host:1671084763=62.210.245.199 author:1671063096=Yonle diff:1671063096:1671063012:=94,101c94,101%0a%3c honk is also known for it's humorous UI. Here's some UI info to get you started: \\%0a%3c %0a%3c - @@it's honking time@@ will create a post \\%0a%3c - @@bonk@@ repost, or reblog. \\%0a%3c - @@honk back@@ reply to a post \\%0a%3c - @@zonk@@ Delete a post \\%0a%3c - @@ack@@ like a post \\%0a%3c - @@badonk@@ react to a post \\%0a\ No newline at end of file%0a---%0a> honk is also known for it's humorous UI. Here's some UI to get you started: \\%0a> %0a> - @@it's honking time@@ will create a post%0a> - @@bonk@@ repost, or reblog.%0a> - @@honk back@@ reply to a post%0a> - @@zonk@@ Delete a post%0a> - @@ack@@ like a post%0a> - @@badonk@@ react to a post%0a\ No newline at end of file%0a host:1671063096=182.1.19.196 author:1671063012=Yonle diff:1671063012:1671063012:=1,101d0%0a%3c (:title honk:)%0a%3c [[https://humungus.tedunangst.com/r/honk|honk]] is an Activitypub software that focused on Single-user instance. \\%0a%3c %0a%3c !! Install%0a%3c [[https://humungus.tedunangst.com/r/honk|honk]] is available at OpenBSD ports.%0a%3c [@%0a%3c # pkg_add honk%0a%3c @]%0a%3c %0a%3c !! Setting up%0a%3c We need to access @@/var/honk@@ to setup database. So login as root%0a%3c [@%0a%3c $ doas su%0a%3c @]%0a%3c %0a%3c Go to @@/var/honk@@, Then set up database.%0a%3c [@%0a%3c # cd /var/honk%0a%3c # doas -u _honk honk init%0a%3c username: yourusername%0a%3c password:%0a%3c listenaddr: 127.0.0.1:4000%0a%3c servername: example.com%0a%3c @]%0a%3c %0a%3c Replace @@yourusername@@ with your username, @@example.com@@ to your hostname.%0a%3c %0a%3c Then start the server.%0a%3c [@%0a%3c # rcctl start honk%0a%3c @]%0a%3c %0a%3c If server succesfully started, You may start it during boot.%0a%3c [@%0a%3c # rcctl enable honk%0a%3c @]%0a%3c %0a%3c !! Configuring relayd.conf%0a%3c relayd will be used as the reverse proxy sitting in front of pleroma. Insert the following configuration in @@/etc/relayd.conf@@:%0a%3c %0a%3c [@%0a%3c # $OpenBSD: relayd.conf,v 1.4 2018/03/23 09:55:06 claudio Exp $%0a%3c %0a%3c ext_inet="%3cIPv4 address>"%0a%3c ext_inet6="%3cIPv6 address>"%0a%3c %0a%3c table %3chonk_server> { 127.0.0.1 }%0a%3c table %3chttpd_server> { 127.0.0.1 }%0a%3c %0a%3c http protocol honk { # Protocol for upstream honk server%0a%3c #tcp { nodelay, sack, socket buffer 65536, backlog 128 } # Uncomment and adjust as you see fit%0a%3c tls { keypair example.com }%0a%3c %0a%3c # Forward some paths to the local server (as honk won't respond to them as you might want)%0a%3c pass request quick path "/robots.txt" forward to %3chttpd_server>%0a%3c %0a%3c # Append a bunch of headers%0a%3c match request header append "X-Forwarded-For" value "$REMOTE_ADDR" # This two header and the next one are not strictly required by honk but adding them won't hurt%0a%3c match request header append "X-Forwarded-By" value "$SERVER_ADDR:$SERVER_PORT"%0a%3c %0a%3c match request header append "Connection" value "upgrade"%0a%3c }%0a%3c %0a%3c relay www {%0a%3c listen on $ext_inet port https tls # Comment to disable listening on IPv4%0a%3c %0a%3c protocol honk%0a%3c %0a%3c forward to %3chonk_server> port 4000%0a%3c }%0a%3c %0a%3c relay www6 {%0a%3c listen on $ext_inet6 port https tls # Comment to disable listening on IPv6%0a%3c %0a%3c protocol honk%0a%3c %0a%3c forward to %3chonk_server> port 4000%0a%3c }%0a%3c @]%0a%3c %0a%3c Change @@example.com@@ with your instance domain.%0a%3c %0a%3c Again, change @@%3cIPv4 address>@@ and @@%3cIPv6 address>@@ to your server's address(es) and comment one of the two listen options if needed.%0a%3c %0a%3c Check the configuration with @@relayd -n@@, if it is OK enable and start relayd (as root):%0a%3c [@%0a%3c # rcctl enable relayd%0a%3c # rcctl start relayd%0a%3c @]%0a%3c %0a%3c And finally, You can visit https://example.com to see your instance.%0a%3c %0a%3c !! User interface basic%0a%3c honk is also known for it's humorous UI. Here's some UI to get you started: \\%0a%3c %0a%3c - @@it's honking time@@ will create a post%0a%3c - @@bonk@@ repost, or reblog.%0a%3c - @@honk back@@ reply to a post%0a%3c - @@zonk@@ Delete a post%0a%3c - @@ack@@ like a post%0a%3c - @@badonk@@ react to a post%0a\ No newline at end of file%0a host:1671063012=103.173.75.170