Blob


1 version=pmwiki-2.3.20 ordered=1 urlencoded=1
2 agent=Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0
3 author=Posterdati
4 charset=UTF-8
5 csum=OpenBSD, xorg, xenodm, monitors
6 ctime=1686496778
7 host=79.19.212.248
8 name=Openbsd.Xenodm
9 rev=16
10 targets=
11 text=!! xenodm%0a%0axenodm is the fork on OpenBSD of xdm. It provides a nice interface and a customizable greeter for xorg session.\\%0axenodm is installed directly on installation/upgrade as part of xorg (xenocara) and could be upgraded\\%0aor reinstalled via sysupgrade or ports. It is a really nice, minimalistic, login/session manager and it is fully\\%0aconfigurable. To start xorg at boot, the user should perform:%0a%0a'''$ doas rcctl enable xenodm'''%0a%0aand to launch it:%0a%0a'''$ doas rcctl restart xenodm'''%0a%0aif no errors showed up, you're ready to go with the standard OpenBSD (tested on 7.3) login greeter.%0a%0a%0a!!! The case.%0a%0aThis article was created with the intent of provide an easy way to choose a video output at boot for\\%0axenodm. The test case was set up on an ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:\\%0a%0aIntel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev. 06)\\%0a%0awhich provide two video output:\\%0a%0a'''eDP-1'''\\%0a'''HDMI-2'''\\%0a%0athis system is fitted with an Intel Core i3 (socket 1150) 3 GHz CPU and 4 GB DDR3 SODDIM RAM.\\%0aThe OS is OpenBSD 7.3 (upgraded from 7.2). The machine is working as firewall/router and\\%0aasterisk server connecting the home LAN to a CISCO 887VA modem. Initially xorg choose HDMI-2\\%0aas primary output even after the upgrade to 7.2, until some time ago when, after a reboot,\\%0ait choose eDP-1 leaving the 1680x1050 lcd monitor connected to HDMI-2 as secondary display.\\%0aTo choose a video output without add or modify the xorg configuration files, it is suffice\\%0ato instruct xenodm to execute xrandr at startup. Based on original /etc/X11/xenodm/Xsetup_0 file\\%0awe can modify as follows:%0a%0aAttach:Xsetup_0
12 time=1686501039
13 author:1686501039=Posterdati
14 csum:1686501039=OpenBSD, xorg, xenodm, monitors
15 diff:1686501039:1686501019:=
16 host:1686501039=79.19.212.248
17 author:1686501019=Posterdati
18 diff:1686501019:1686501016:=
19 host:1686501019=79.19.212.248
20 author:1686501016=Posterdati
21 diff:1686501016:1686500971:=38c38%0a%3c Attach:Xsetup_0%0a\ No newline at end of file%0a---%0a> Attach:file.ext%0a\ No newline at end of file%0a
22 host:1686501016=79.19.212.248
23 author:1686500971=Posterdati
24 csum:1686500971=OpenBSD, xenodm, xorg, monitors
25 diff:1686500971:1686500969:=
26 host:1686500971=79.19.212.248
27 author:1686500969=Posterdati
28 csum:1686500969=OpenBSD, xenodm, xorg, monitors
29 diff:1686500969:1686500888:=38d37%0a%3c Attach:file.ext%0a\ No newline at end of file%0a
30 host:1686500969=79.19.212.248
31 author:1686500888=Posterdati
32 csum:1686500888=OpenBSD, xenodm, xorg, monitors
33 diff:1686500888:1686500821:=37a38%0a> Attach:/home/angel/Development/shell/Xsetup_0%0a\ No newline at end of file%0a
34 host:1686500888=79.19.212.248
35 author:1686500821=Posterdati
36 diff:1686500821:1686500718:=38c38,65%0a%3c Attach:/home/angel/Development/shell/Xsetup_0%0a\ No newline at end of file%0a---%0a> #!/bin/sh%0a> # $OpenBSD: Xsetup_0.in,v 1.1 2021/08/30 15:38:27 matthieu Exp $%0a> %0a> prefix="/usr/X11R6"%0a> exec_prefix="${prefix}"%0a> %0a> monitor="HDMI-2"%0a> %0a> monitors=$(${exec_prefix}/bin/xrandr --listmonitors)%0a> echo "Active output monitors: " ${monitors}%0a> echo "Selected primary monitor: " ${monitor}%0a> if [ $(echo ${monitors} | grep -c ${monitor}) -ge 1 ]; then%0a> ${exec_prefix}/bin/xrandr --output ${monitor} --primary%0a> fi%0a> %0a> ${exec_prefix}/bin/xsetroot -fg \#6f6f6f -bg \#bfbfbf -bitmap ${prefix}/include/X11/bitmaps/root_weave%0a> %0a> ${exec_prefix}/bin/xconsole -geometry 480x130-0-0 -daemon -notify -verbose -fn fixed -exitOnFail%0a> %0a> # install package openbsd-backgrounds%0a> # then uncomment:%0a> #%0a> # if test -x /usr/local/bin/openbsd-wallpaper%0a> # then%0a> # /usr/local/bin/openbsd-wallpaper%0a> # fi%0a> %0a> # sxpm OpenBSD.xpm &%0a\ No newline at end of file%0a
37 host:1686500821=79.19.212.248
38 author:1686500718=Posterdati
39 diff:1686500718:1686498513:=34,65d33%0a%3c To choose a video output without add or modify the xorg configuration files, it is suffice\\%0a%3c to instruct xenodm to execute xrandr at startup. Based on original /etc/X11/xenodm/Xsetup_0 file\\%0a%3c we can modify as follows:%0a%3c %0a%3c #!/bin/sh%0a%3c # $OpenBSD: Xsetup_0.in,v 1.1 2021/08/30 15:38:27 matthieu Exp $%0a%3c %0a%3c prefix="/usr/X11R6"%0a%3c exec_prefix="${prefix}"%0a%3c %0a%3c monitor="HDMI-2"%0a%3c %0a%3c monitors=$(${exec_prefix}/bin/xrandr --listmonitors)%0a%3c echo "Active output monitors: " ${monitors}%0a%3c echo "Selected primary monitor: " ${monitor}%0a%3c if [ $(echo ${monitors} | grep -c ${monitor}) -ge 1 ]; then%0a%3c ${exec_prefix}/bin/xrandr --output ${monitor} --primary%0a%3c fi%0a%3c %0a%3c ${exec_prefix}/bin/xsetroot -fg \#6f6f6f -bg \#bfbfbf -bitmap ${prefix}/include/X11/bitmaps/root_weave%0a%3c %0a%3c ${exec_prefix}/bin/xconsole -geometry 480x130-0-0 -daemon -notify -verbose -fn fixed -exitOnFail%0a%3c %0a%3c # install package openbsd-backgrounds%0a%3c # then uncomment:%0a%3c #%0a%3c # if test -x /usr/local/bin/openbsd-wallpaper%0a%3c # then%0a%3c # /usr/local/bin/openbsd-wallpaper%0a%3c # fi%0a%3c %0a%3c # sxpm OpenBSD.xpm &%0a\ No newline at end of file%0a
40 host:1686500718=79.19.212.248
41 author:1686498513=Posterdati
42 diff:1686498513:1686497350:=14,21c14,16%0a%3c if no errors showed up, you're ready to go with the standard OpenBSD (tested on 7.3) login greeter.%0a%3c %0a%3c %0a%3c !!! The case.%0a%3c %0a%3c This article was created with the intent of provide an easy way to choose a video output at boot for\\%0a%3c xenodm. The test case was set up on an ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:\\%0a%3c %0a---%0a> if no errors showed up, you're ready to go with the standard OpenBSD (tested on 7.3) login greeter. Now for some\\%0a> reason, xorg worked on a ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:\\%0a> %0a29,33d23%0a%3c this system is fitted with an Intel Core i3 (socket 1150) 3 GHz CPU and 4 GB DDR3 SODDIM RAM.\\%0a%3c The OS is OpenBSD 7.3 (upgraded from 7.2). The machine is working as firewall/router and\\%0a%3c asterisk server connecting the home LAN to a CISCO 887VA modem. Initially xorg choose HDMI-2\\%0a%3c as primary output even after the upgrade to 7.2, until some time ago when, after a reboot,\\%0a%3c it choose eDP-1 leaving the 1680x1050 lcd monitor connected to HDMI-2 as secondary display.\\%0a
43 host:1686498513=79.19.212.248
44 author:1686497350=Posterdati
45 diff:1686497350:1686497332:=14,22c14,21%0a%3c if no errors showed up, you're ready to go with the standard OpenBSD (tested on 7.3) login greeter. Now for some\\%0a%3c reason, xorg worked on a ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:\\%0a%3c %0a%3c Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev. 06)\\%0a%3c %0a%3c which provide two video output:\\%0a%3c %0a%3c '''eDP-1'''\\%0a%3c '''HDMI-2'''\\%0a---%0a> if no errors showed up, you're ready to go with the standard OpenBSD (tested on 7.3) login greeter. Now for some reason, xorg worked on a ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:%0a> %0a> Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev. 06)%0a> %0a> which provide two video output:%0a> %0a> '''eDP-1'''%0a> '''HDMI-2'''%0a
46 host:1686497350=79.19.212.248
47 author:1686497332=Posterdati
48 diff:1686497332:1686497283:=20,21c20,21%0a%3c '''eDP-1'''%0a%3c '''HDMI-2'''%0a---%0a> '''eDP-1%0a> HDMI-2'''%0a
49 host:1686497332=79.19.212.248
50 author:1686497283=Posterdati
51 diff:1686497283:1686497222:=3,6c3,5%0a%3c xenodm is the fork on OpenBSD of xdm. It provides a nice interface and a customizable greeter for xorg session.\\%0a%3c xenodm is installed directly on installation/upgrade as part of xorg (xenocara) and could be upgraded\\%0a%3c or reinstalled via sysupgrade or ports. It is a really nice, minimalistic, login/session manager and it is fully\\%0a%3c configurable. To start xorg at boot, the user should perform:%0a---%0a> xenodm is the fork on OpenBSD of xdm. It provides a nice interface and a customizable greeter for xorg session.%0a> xenodm is installed directly on installation/upgrade as part of xorg (xenocara) and could be upgraded or reinstalled%0a> via sysupgrade or ports. It is a really nice, minimalistic, login/session manager and it is fully configurable. To start xorg at boot, the user should perform:%0a
52 host:1686497283=79.19.212.248
53 author:1686497222=Posterdati
54 diff:1686497222:1686497157:=13c13%0a%3c if no errors showed up, you're ready to go with the standard OpenBSD (tested on 7.3) login greeter. Now for some reason, xorg worked on a ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:%0a---%0a> now for some reason, xorg worked on a ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:%0a
55 host:1686497222=79.19.212.248
56 author:1686497157=Posterdati
57 diff:1686497157:1686497125:=7,8c7,8%0a%3c '''$ doas rcctl enable xenodm'''%0a%3c %0a---%0a> $ doas rcctl enable xenodm%0a> %0a11,12c11,12%0a%3c '''$ doas rcctl restart xenodm'''%0a%3c %0a---%0a> $ doas rcctl restart xenodm%0a> %0a19,20c19,20%0a%3c '''eDP-1%0a%3c HDMI-2'''%0a---%0a> eDP-1%0a> HDMI-2%0a
58 host:1686497157=79.19.212.248
59 author:1686497125=Posterdati
60 diff:1686497125:1686496778:=2a3%0a> %0a13,21c14%0a%3c now for some reason, xorg worked on a ASUSTeK COMPUTER INC. Q87T motherboard with integrated Intel graphics:%0a%3c %0a%3c Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev. 06)%0a%3c %0a%3c which provide two video output:%0a%3c %0a%3c eDP-1%0a%3c HDMI-2%0a%3c %0a---%0a> now%0a\ No newline at end of file%0a
61 host:1686497125=79.19.212.248
62 author:1686496778=Posterdati
63 diff:1686496778:1686496778:=1,14d0%0a%3c !! xenodm%0a%3c %0a%3c %0a%3c xenodm is the fork on OpenBSD of xdm. It provides a nice interface and a customizable greeter for xorg session.%0a%3c xenodm is installed directly on installation/upgrade as part of xorg (xenocara) and could be upgraded or reinstalled%0a%3c via sysupgrade or ports. It is a really nice, minimalistic, login/session manager and it is fully configurable. To start xorg at boot, the user should perform:%0a%3c %0a%3c $ doas rcctl enable xenodm%0a%3c %0a%3c and to launch it:%0a%3c %0a%3c $ doas rcctl restart xenodm%0a%3c %0a%3c now%0a\ No newline at end of file%0a
64 host:1686496778=79.19.212.248