Blob


1 version=pmwiki-2.2.130 ordered=1 urlencoded=1
2 agent=Mozilla/5.0 (X11; OpenBSD amd64; rv:76.0) Gecko/20100101 Firefox/76.0
3 author=jrmu
4 charset=UTF-8
5 csum=
6 ctime=1597059807
7 host=38.81.163.143
8 name=OpenbsdNet.IPv6
9 rev=3
10 targets=
11 text=If you chose DHCP when first installing the OS, you may want to edit the networking configuration manually (to switch to a static IP).%0a%0aOpenbsd requires one hostname.if per device, where the letters 'if' are replaced with an abbreviation followed by a device number. So, for example, an Atheros IEEE 802.11a/b/g/n wifi device is abbreviated by athn0, and will need an /etc/hostname.athn0 file.%0a%0aReplace if with your own device name. Inside /etc/hostname.if0, put:%0a%0a[@%0ainet 192.168.1.2 255.255.255.0%0ainet alias 192.168.1.3 255.255.255.0%0ainet6 2001:0db8:0000:0000:0000:0000:0000:0000 48%0ainet6 alias 2001:0db8:0000:0000:9b1d:3511:387e:143a 48%0ainet6 alias 2001:0db8:0000:0000:1465:fed1:8daf:66ff 48%0ainet6 alias 2001:0db8:0000:0000:11b4:4a36:2941:d6bd 48%0ainet6 alias 2001:0db8:0000:0000:ad2c:5b99:2b1a:89d1 48%0ainet6 alias 2001:0db8:0000:0000:921d:28ad:4729:8d93 48%0ainet6 alias 2001:0db8:0000:0000:c9bb:45f7:c494:1fc1 48%0ainet6 alias 2001:0db8:0000:0000:5142:9b81:dec2:186c 48%0ainet6 alias 2001:0db8:0000:0000:a118:dd85:a14f:72d7 48%0ainet6 alias 2001:0db8:0000:0000:91f2:4943:de98:c9d5 48%0ainet6 alias 2001:0db8:0000:0000:18a4:1ca3:5d31:2ddc 48%0ainet6 alias 2001:0db8:0000:0000:31af:1656:16cf:611a 48%0ainet6 alias 2001:0db8:0000:0000:8d27:5b44:3e75:4b86 48%0ainet6 alias 2001:0db8:0000:0000:a259:79f6:fa54:a5e2 48%0ainet6 alias 2001:0db8:0000:0000:59d8:f8ae:18a3:3644 48%0ainet6 alias 2001:0db8:0000:0000:1dc7:c1c7:7b16:1151 48%0ainet6 alias 2001:0db8:0000:0000:1c46:b131:e9de:edc1 48%0ainet6 alias 2001:0db8:0000:0000:e72b:6165:b6fb:161f 48%0ainet6 alias 2001:0db8:0000:0000:244c:47c2:f8fd:4bc2 48%0ainet6 alias 2001:0db8:0000:0000:f664:e887:826d:64c5 48%0ainet6 alias 2001:0db8:0000:0000:f8e7:1ca5:4852:9e78 48%0ainet6 alias 2001:0db8:0000:0000:59e5:7568:ab7f:289f 48%0ainet6 alias 2001:0db8:0000:0000:111e:6834:a1b1:64ff 48%0ainet6 alias 2001:0db8:0000:0000:de32:1311:18d4:6f8b 48%0ainet6 alias 2001:0db8:0000:0000:5714:1f81:156f:572b 48%0ainet6 alias 2001:0db8:0000:0000:2589:ad14:872a:fa94 48%0ainet6 alias 2001:0db8:0000:0000:5b15:e14f:812e:fa84 48%0ainet6 alias 2001:0db8:0000:0000:5982:9c11:c2eb:c6ed 48%0ainet6 alias 2001:0db8:0000:0000:abaf:88e4:69e1:f2a5 48%0ainet6 alias 2001:0db8:0000:0000:a52b:5de1:ceba:b65a 48%0ainet6 alias 2001:0db8:0000:0000:7e8b:f585:f2e7:66a1 48%0ainet6 alias 2001:0db8:0000:0000:46ad:1add:cb77:154b 48%0ainet6 alias 2001:0db8:0000:0000:b664:368a:d94b:3ce8 48%0a@]%0a%0aLet's look at the first two lines:%0a%0a%3ccode>%0ainet 192.168.1.2 255.255.255.0%0ainet alias 192.168.1.3 255.255.255.0%0a%3c/code>%0a%0aThe first line will set the device to use the static IP 192.168.1.2 with subnet mask 255.255.255.0. The second line will allow the device to use a second static IP, 192.168.1.3. It will be aliased to the first and have the same subnet mask.%0a%0aLet's look at lines 3 and 4:%0a%0a%3ccode>%0ainet6 2001:0db8:0000:0000:0000:0000:0000:0000 48%0ainet6 alias 2001:0db8:0000:0000:9b1d:3511:387e:143a 48%0a%3c/code>%0a%0aThe first one sets the device to use the static IPv6 address 2001:0db8:: with a /48 subnet, and the second one creates another IPv6 address 2001:0db8:0000:0000:9b1d:3511:387e:143a with a /48 subnet, aliased to the first IPv6 address. In this way, you can create dozens of unique IPv6 addresses so that each user on a shell account or bouncer can get a unique IPv6 address.%0a%0aYou will also need to specify the default gateway in /etc/mygate:%0a%0a%3ccode>%0a192.168.1.1%0a2001:0db8:0000:0000::1%0a%3c/code>%0a%0aSometimes, to restart networking, I will run:%0a%0a%3ccode>%0a$ doas sh /etc/netstart%0a%3c/code>%0a%0aBut this doesn't seem to properly reset the networking sometimes.%0a%0aWatch out! Iked, without the -6 flag, will block all IPv6 traffic.%0a%0aIf you later decide you want to add a new ipv6 address, use ifconfig:%0a%0a%3ccode>%0a$ doas ifconfig if0 inet6 2001:0db8::/64%0a%3c/code>%0a%0aTo delete the IPv6 address:%0a%0a%3ccode>%0a$ doas ifconfig if0 inet6 2001:0db8::/64 delete%0a%3c/code>%0a%0aReplace if0 with your specific interface.%0a%0a----%0a%0aTo test if an IPv6 address is working, you can use netcat to connect to an IRC network that supports IPv6:%0a%0a%3ccode>%0a$ nc -s 2001:0db8:: ipv6.ircnow.org 6667%0anick newnick%0auser newuser * * :newuser%0aPING :12345%0aPONG :12345%0a%3c/code>%0a%0aIf that loads a message, then you configured the IPv6 address 2001:0db8:: correctly.
12 time=1597059987
13 author:1597059987=jrmu
14 diff:1597059987:1597059971:=7c7%0a%3c [@%0a---%0a> @[%0a43c43%0a%3c @]%0a---%0a> ]@%0a
15 host:1597059987=38.81.163.143
16 author:1597059971=jrmu
17 diff:1597059971:1597059807:=7c7%0a%3c @[%0a---%0a> %3ccode>%0a43c43%0a%3c ]@%0a---%0a> %3c/code>%0a
18 host:1597059971=38.81.163.143
19 author:1597059807=jrmu
20 diff:1597059807:1597059807:=1,106d0%0a%3c If you chose DHCP when first installing the OS, you may want to edit the networking configuration manually (to switch to a static IP).%0a%3c %0a%3c Openbsd requires one hostname.if per device, where the letters 'if' are replaced with an abbreviation followed by a device number. So, for example, an Atheros IEEE 802.11a/b/g/n wifi device is abbreviated by athn0, and will need an /etc/hostname.athn0 file.%0a%3c %0a%3c Replace if with your own device name. Inside /etc/hostname.if0, put:%0a%3c %0a%3c %3ccode>%0a%3c inet 192.168.1.2 255.255.255.0%0a%3c inet alias 192.168.1.3 255.255.255.0%0a%3c inet6 2001:0db8:0000:0000:0000:0000:0000:0000 48%0a%3c inet6 alias 2001:0db8:0000:0000:9b1d:3511:387e:143a 48%0a%3c inet6 alias 2001:0db8:0000:0000:1465:fed1:8daf:66ff 48%0a%3c inet6 alias 2001:0db8:0000:0000:11b4:4a36:2941:d6bd 48%0a%3c inet6 alias 2001:0db8:0000:0000:ad2c:5b99:2b1a:89d1 48%0a%3c inet6 alias 2001:0db8:0000:0000:921d:28ad:4729:8d93 48%0a%3c inet6 alias 2001:0db8:0000:0000:c9bb:45f7:c494:1fc1 48%0a%3c inet6 alias 2001:0db8:0000:0000:5142:9b81:dec2:186c 48%0a%3c inet6 alias 2001:0db8:0000:0000:a118:dd85:a14f:72d7 48%0a%3c inet6 alias 2001:0db8:0000:0000:91f2:4943:de98:c9d5 48%0a%3c inet6 alias 2001:0db8:0000:0000:18a4:1ca3:5d31:2ddc 48%0a%3c inet6 alias 2001:0db8:0000:0000:31af:1656:16cf:611a 48%0a%3c inet6 alias 2001:0db8:0000:0000:8d27:5b44:3e75:4b86 48%0a%3c inet6 alias 2001:0db8:0000:0000:a259:79f6:fa54:a5e2 48%0a%3c inet6 alias 2001:0db8:0000:0000:59d8:f8ae:18a3:3644 48%0a%3c inet6 alias 2001:0db8:0000:0000:1dc7:c1c7:7b16:1151 48%0a%3c inet6 alias 2001:0db8:0000:0000:1c46:b131:e9de:edc1 48%0a%3c inet6 alias 2001:0db8:0000:0000:e72b:6165:b6fb:161f 48%0a%3c inet6 alias 2001:0db8:0000:0000:244c:47c2:f8fd:4bc2 48%0a%3c inet6 alias 2001:0db8:0000:0000:f664:e887:826d:64c5 48%0a%3c inet6 alias 2001:0db8:0000:0000:f8e7:1ca5:4852:9e78 48%0a%3c inet6 alias 2001:0db8:0000:0000:59e5:7568:ab7f:289f 48%0a%3c inet6 alias 2001:0db8:0000:0000:111e:6834:a1b1:64ff 48%0a%3c inet6 alias 2001:0db8:0000:0000:de32:1311:18d4:6f8b 48%0a%3c inet6 alias 2001:0db8:0000:0000:5714:1f81:156f:572b 48%0a%3c inet6 alias 2001:0db8:0000:0000:2589:ad14:872a:fa94 48%0a%3c inet6 alias 2001:0db8:0000:0000:5b15:e14f:812e:fa84 48%0a%3c inet6 alias 2001:0db8:0000:0000:5982:9c11:c2eb:c6ed 48%0a%3c inet6 alias 2001:0db8:0000:0000:abaf:88e4:69e1:f2a5 48%0a%3c inet6 alias 2001:0db8:0000:0000:a52b:5de1:ceba:b65a 48%0a%3c inet6 alias 2001:0db8:0000:0000:7e8b:f585:f2e7:66a1 48%0a%3c inet6 alias 2001:0db8:0000:0000:46ad:1add:cb77:154b 48%0a%3c inet6 alias 2001:0db8:0000:0000:b664:368a:d94b:3ce8 48%0a%3c %3c/code>%0a%3c %0a%3c Let's look at the first two lines:%0a%3c %0a%3c %3ccode>%0a%3c inet 192.168.1.2 255.255.255.0%0a%3c inet alias 192.168.1.3 255.255.255.0%0a%3c %3c/code>%0a%3c %0a%3c The first line will set the device to use the static IP 192.168.1.2 with subnet mask 255.255.255.0. The second line will allow the device to use a second static IP, 192.168.1.3. It will be aliased to the first and have the same subnet mask.%0a%3c %0a%3c Let's look at lines 3 and 4:%0a%3c %0a%3c %3ccode>%0a%3c inet6 2001:0db8:0000:0000:0000:0000:0000:0000 48%0a%3c inet6 alias 2001:0db8:0000:0000:9b1d:3511:387e:143a 48%0a%3c %3c/code>%0a%3c %0a%3c The first one sets the device to use the static IPv6 address 2001:0db8:: with a /48 subnet, and the second one creates another IPv6 address 2001:0db8:0000:0000:9b1d:3511:387e:143a with a /48 subnet, aliased to the first IPv6 address. In this way, you can create dozens of unique IPv6 addresses so that each user on a shell account or bouncer can get a unique IPv6 address.%0a%3c %0a%3c You will also need to specify the default gateway in /etc/mygate:%0a%3c %0a%3c %3ccode>%0a%3c 192.168.1.1%0a%3c 2001:0db8:0000:0000::1%0a%3c %3c/code>%0a%3c %0a%3c Sometimes, to restart networking, I will run:%0a%3c %0a%3c %3ccode>%0a%3c $ doas sh /etc/netstart%0a%3c %3c/code>%0a%3c %0a%3c But this doesn't seem to properly reset the networking sometimes.%0a%3c %0a%3c Watch out! Iked, without the -6 flag, will block all IPv6 traffic.%0a%3c %0a%3c If you later decide you want to add a new ipv6 address, use ifconfig:%0a%3c %0a%3c %3ccode>%0a%3c $ doas ifconfig if0 inet6 2001:0db8::/64%0a%3c %3c/code>%0a%3c %0a%3c To delete the IPv6 address:%0a%3c %0a%3c %3ccode>%0a%3c $ doas ifconfig if0 inet6 2001:0db8::/64 delete%0a%3c %3c/code>%0a%3c %0a%3c Replace if0 with your specific interface.%0a%3c %0a%3c ----%0a%3c %0a%3c To test if an IPv6 address is working, you can use netcat to connect to an IRC network that supports IPv6:%0a%3c %0a%3c %3ccode>%0a%3c $ nc -s 2001:0db8:: ipv6.ircnow.org 6667%0a%3c nick newnick%0a%3c user newuser * * :newuser%0a%3c PING :12345%0a%3c PONG :12345%0a%3c %3c/code>%0a%3c %0a%3c If that loads a message, then you configured the IPv6 address 2001:0db8:: correctly.%0a\ No newline at end of file%0a
21 host:1597059807=38.81.163.143